Learn Enough Text Editor to Be Dangerous ebooks

Dec 7, 2015 • posted by Michael Hartl

Having incorporated helpful reader feedback (thanks!) on the draft of Learn Enough Text Editor to Be Dangerous, I’ve just released the final version, including PDF, EPUB, and MOBI ebooks. The price is just $9, and with a PDF that runs to well over 100 pages, that’s less than ten cents per page!

Learn Enough Text Editor to Be Dangerous is part of a series of Learn Enough to Be Dangerous tutorials designed to complement and expand on the prerequisites to the Ruby on Rails Tutorial. As noted before, Learn Enough Text Editor to Be Dangerous is an introduction to text editors that assumes no prerequisites other than a familiarity with the Unix command line (such as that provided by Learn Enough Command Line to Be Dangerous). Topics include Minimum Viable Vim, an introduction to “modern” text editors like Atom and Sublime Text, and more advanced features like editing source code and global find and replace.

As always, I appreciate any feedback or suggestions you may have, whether you’re a relative beginner or an expert. I especially appreciate bug and typo reports (no matter how small). With the streamlined publication process made possible by the Softcover toolchain, I can usually deploy corrections within minutes of receiving them. Please email any feedback to [email protected] And remember that you can get a 33% launch discount on the Learn Enough Text Editor to Be Dangerous ebooks through Monday, December 14.

Discuss this post on Hacker News

MORE ARTICLES LIKES THIS:
ebooks-launch , dev-basics